关于OSPF的network配置

作者:无名 - 网络编程 -
OSPF是link state protocol,主要是interface状态(如ip address,mask,Hello time....)这些信息在
  
  Routers间建立adjency的过程中会通过LSAs被互换,直到同Area收敛,所有Routers有同样的link state database,然后以自己为根(root)建立SPF tree,最后在根据SPF计算出route table.Area内任何一个interface的变化都会被Update.
  
  我们再看看OSPF执行时的过程:(简单举例)
  
  int s1
  ip add 10.1.1.1 255.255.255.0 (10.1.1.1/24)
  
  int s2
  ip add 172.2.0.1 255.255.255.0 (172.2.0.1/24)
  
  int s3
  ip add 172.3.0.1 255.255.0.0 (172.3.0.1/16)
  
  int s4
  ip add 172.4.0.1 255.255.0.0 (172.4.0.1/16)
  
  route ospf 10
  network 10.1.1.1 0.0.0.0 area 0
  network 172.2.0.0 0.0.255.255 area 0
  
  当进入OSPF 10,OSPF首先执行network 10.1.1.1 0.0.0.0,查找interface address,有匹配s0,分配至Area 0,然后再执行network 172.2.0.0.0.0.255.255 aera 0,匹配s2->Area 0,最后我们在其它Routers上看到的信息是:
  
  172.16.0.0/24 is subnetted, 1 subnets
  O 172.16.0.0 [110/128] via 192.168.0.1, 00:00:00, Serialx
  10.0.0.0/24 is subnetted, 1 subnets
  O 10.1.1.0 [110/74] via 192.168.0.1, 00:00:05, Serialx
  
  在着里可以看到submask是24,忽略了在network中配制的inverse mask,为什么?
  
  我们再看当添加新的network后有什么结果?
  route ospf 10
  network 10.1.1.1 0.0.0.0 area 0
  network 172.2.0.0 0.0.255.255 area 0
  network 172.0.0.0 0.255.255.255 area 1
  network 0.0.0.0 0.0.0.0 area 2
  show ip route
  Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
  D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
  N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
  E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
  i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
  * - candidate default, U - per-user static route, o - ODR
  P - periodic downloaded static route
  
  Gateway of last resort is not set
  O IA 172.3.0.0/16 [110/933] via 192.168.0.1, 00:00:05, Serialx
  O IA 172.4.0.0/16 [110/933] via 192.168.0.1, 00:00:02, Serialx
  172.16.0.0/24 is subnetted, 1 subnets
  O 172.16.0.0 [110/128] via 192.168.0.1, 00:00:10, Serialx
  10.0.0.0/24 is subnetted, 1 subnets
  O 10.1.1.0 [110/74] via 192.168.0.1, 00:00:05, Serialx
  
  这里s3,s4都在Area 1(被标记为IA掩码16)。
  
  总结:实际的网络范围在interface mask中已经说明了,这在所有的Routers的Link state database 被清楚标记,不会因OSPF的network配置而发生改变。而在OSPF的network配置中,inverse mask只是起到指明在本Router的OSPF process 中的网络范围的作用,如network 172.0.0.0 0.255.255.255指定范围从172.0.0.0 ~ 172.255.255.255,在次范围中的所有interface分配至Area 1,最后其他所有的地址被分配到Area 2。
  
  如果在Stub Area 中,没有Loopback interface的情况下,甚至可以简单配制为
  
  router ospf 20
  network 0.0.0.0 255.255.255.255 area x
  
  这样就不用单独指定网络范围了。
  
  在其它类型中,推荐配置使用interface ip address,0.0.0.0即精确匹配,以防止错误发生。如:
  
  network 10.1.1.1 0.0.0.0 area 0 文章录入:csh    责任编辑:csh 

IT人知识库 该篇知识地址:http://www.itpeo.net/12746/389437.html





标签 关于配置

CISCO基础ARP

ARP Lab 查看 ARP 表:1. 首先需要连接到Router1并查看ARP表。 - Click Here... ...

CISCO基础CDP

CDP 1. 在第一台路由器(Router1)上,进入到终端配置模式 - Cl ick Here to View An... ...

CISCO扫盲基础命令

注:本文仅供扫盲使用,完全没有什么技术性可言,考NA而没有基础的朋友可以看一下。1. 进入路由器操作界面. - Clic... ...

探讨关于OSPF的network配置

一般什么时候用完整的IP地址,什么时候用网络地址    OSPF是link state protocol,主要是inte... ...

OSPFv3动态路由协议在NBMA链路上的实现

1 问题的提出  随着网络信息时代的到来,Internet技术在全球范围内得到了迅速的发展,开放最短路径优先(Open ... ...

了解路由器中的管理间距和量度参数

谈到路由协议和路由器时,管理间距(administrative distance)和量度(Metrics)是两组重要的参... ...

SmoothWall 防火墙软路由安装+配置详解

一、前言:本来搜索DRL但是看到没有什么关于SW更好的教程,为了方便大家所以作了这个教程。1、感谢ahui兄的软件简介:... ...

选择多WAN宽带路由器的4大理由

互联网已深深融入我们的生活,不再是点缀,而更多的是依赖!在现有基础上大幅度扩展网络应用又一次摆在了人们面前,而现有的带宽... ...

无线局域网

无线局域网(Wireless LAN) 为IEEE定义的一个无线网络通信的工业标准(IEEE802.11)。无线局域网第... ...

Ruckus首推多媒体无线路由器

新一代Wi-Fi无线局域网络产品开发商Ruckus Wireless,Inc. (Ruckus)日前推出全新产品和技术,... ...

思科漏洞主角林恩访谈路由器是定时炸弹

安全研究员迈克尔·林恩(Michael Lynn)从ISS(互联网安全系统)公司辞职后,不顾思科及ISS公司的阻挠,上周... ...

路由选择原理

路 由 选 择 原 理 1.1路由选择基础知识  路由是将对象从一个地方转达发到另一个地方的一个中继过程   学习和维持... ...

CISCO路由器的基本安装维护

CISCO路由器的基本安装维护 1 控制口连接 先将CISCO2500/1000系列路由器附件中的控制电缆RJ45的一端... ...

CISCO路由器调试

CISCO路由器调试 一、基本设置方式 一般来说,可以用5种方式来设置路由器: 1.Console口接终端或运行终端仿真... ...

Cisco路由器故障诊断技术

1 引言 作为网络工程师,在网络环境出现故障时,及时定位故障并解决故障是十分重要的。本文以CISCO路由式网络为基础,介... ...

双线路策略路由和脚本备份切换

电信和网通的双线路策略路由.并且在其中一条线路断掉后自动切换为单线路,线路恢复后,恢复使用策略路由.电信网关 190.1... ...

宽带路由器死机掉线问题深度分析

经常会在网上看到诸多网友在购买宽带路由器以后,在使用过程中遇到死机频繁掉线问题,给网友带来很多不便,以至于有些产品被网友... ...

单物理接口NAT的总结

要想正确地理解单物理接口NAT,需要正确地理解NAT条件和处理顺序。以下配置引用了坛子里的内容,对被引用内容的原作者表示... ...

网络基础学习之二十路由器的配置

路由器的软件配置相对它的硬件来说更是要复杂许多,它与其它网络接入设备不一样的是,不仅在硬件结构上相当复杂,而且还集成了相... ...

网络基础学习之十九路由器的硬件连接

在了解了路由器的基础知识后,从本篇开始就要正式介入路由器的使用了。本篇所要介绍的就是使用前的基础工作——路由器的硬件连接... ...